Cisco三款VPN路由器產品存在安全漏洞,允許遠端攻擊者執行任意程式碼,請儘速確認並進行修正

研究團隊發現Cisco RV110W、RV130W及RV215W三款VPN路由器產品存在安全性漏洞,肇因於此三款產品之網頁管理介面程式未完整驗證用戶提交的資料,導致未經授權的遠端攻擊者可針對目標設備發送特製的HTTP請求,進而造成遠端攻擊者可以管理員權限執行任意程式碼。

  • CVE編號:
    • CVE-2019-1663
  • 影響產品:
    • RV110W Wireless-N VPN Firewall:韌體版本2.2.1以前的所有版本
    • RV130W Wireless-N Multifunction VPN Router:韌體版本0.3.45前的所有版本
    • RV215W Wireless-N VPN Router:韌體版本3.1.1前的所有版本
  • 解決辦法:

目前Cisco官方已針對此弱點釋出修復版本,可聯絡設備維護廠商或參考以下建議進行更新:

  1. 連線至網址:https://software.cisc o.com/download/home,點擊「Browse All」按鈕。
  2. 按照型號下載更新檔:
    • RV110W Wireless-N VPN Firewall:
      點擊「Routers > Small Business Routers > Small Business RV Series Routers > RV110W Wireless-N VPN Firewall > Wireless Router Firmware」選擇1.2.2.1或後續版本進行下載。
    • RV130W Wireless-N Multifunction VPN Router:
      點擊「Routers > Small Business Routers > Small Business RV Series Routers > RV130W Wireless-N Multifunction VPN Router > Small Business Router Firmware」選擇1.0.3.45或後續版本進行下載。
    • RV215W Wireless-N VPN Router:
      點擊「Routers > Small Business Routers > Small Business RV Series Routers > RV215W Wireless-N VPN Router > Wireless Router Firmware」選擇1.3.1.1或後續版本進行下載。
  1. 使用設備之管理頁面功能進行韌體更新。

資料來源:

  1. https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190227-rmi-cmd-ex
  2. https://www.ithome.com.tw/news/129047
回到頂端