資安研究人員發現存於 Linux 核心長達 8 年的 Dirty Cred 漏洞

美國西北大學的資安研究人員團隊,近來發現 Linux 核心中有一個存在長達 8 年未被發現的漏洞「Dirty Cred」,可能導致駭侵者提升執行權限,並可遠端執行任意程式碼。

該漏洞的 CVE 編號為 CVE-2022-2588,存於 Linux 核心內對於 cls_route 篩選器的實作中,屬於已釋放記憶體漏洞(use-after-free)。駭侵者如果取得本機的 CAP_NET_ADMIN 權限,即可利用此漏洞以進一步提升執行權限,造成系統崩潰或執行任意程式碼。

同一組研究人員,日前在於 Black Hat 資安研討會上揭露另一個存於 Linux 核心版本 5.8 及後續版本的「Dirty Pipe」漏洞(CVE-2022-0847),可輕易繞過 Linux 諸如隨機核心位址與指標完整性檢查等安全機制,利用 Linux 核心的管線機制,在任意檔案中注入資料;而新發現的 Dirty Cred 則不需利用 Linux 核心管線機制,因此使用更加簡便,破壞能力也更大。

研究人員指出,Dirty Cred 的運作原理,是將無權限的核心登入資訊更換成有權限者,無需在核心 heap 中覆寫任何重要資料欄位,只要利用 heap 記憶體重新使用機制,即可取得更高的執行權限。

研究人員也已透過概念證實程式,在 Linux 與 Android 系統上成功實作利用 Dirty Cred 的駭侵攻擊手法。

目前 Linux 開發團隊仍在針對此漏洞發展修補方式,尚未釋出更新;研究人員指出,在虛擬記憶體中將具備權限的登入資訊與不具備權限的登入資訊隔開,以防止跨快取攻擊,可能可以防止駭侵者利用 Dirty Cred 漏洞發動攻擊。

相關連結

  1. TWCERT/CC
  2. New Linux Exploit ‘Dirty Cred’ Revealed at Black Hat
  3. ‘DirtyCred’ Vulnerability Haunting Linux Kernel for 8 Years

Leave a Comment

發佈留言必須填寫的電子郵件地址不會公開。

回到頂端